Puppeteer

Author Topic: TL2 fuel pumps  (Read 145 times)

chefiam1

  • Newbie
  • *
  • Posts: 11
    • View Profile
TL2 fuel pumps
« on: June 05, 2020, 09:49:02 PM »
No fuel pumping to injector!!put shims in took shims out.but if i loosen the valve body a 1/2 turn i get constant fuel. could the valve be put together wrong. it seems on
both  valve bodies crack them 1/4 turn and fuel flows constant. tighten them down and no fuel squirting up.should i pull the pumps?any help appreciated

                                                                                                                                     thanks chef

Willw

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Re: TL2 fuel pumps
« Reply #1 on: June 21, 2020, 05:03:59 PM »
Hi Chef, I usually remove the delivery valve and holder. Check that the D valve is free to move in the body.
Next, push a small brass drift against the plunger (located in the center of the area beneath the delivery valve.)
Turn the engine a few revolutions, you should feel the plunger move back and forth. If no movement is felt, the plunger is stuck. Liquid Wrench is my Penetrating oil of choice.
If the plunger does not free itself, a gentle rap on the brass drift might be required to free it. You may have to turn the engine in a few different positions to ensure that the cam lobe is not directly under the pump.
Daily driver '97 GMC W4 tipper on WVO/Kerosene mix.
6/1 clone standby generator.
Too many projects.

chefiam1

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: TL2 fuel pumps
« Reply #2 on: July 11, 2020, 08:20:13 AM »
Thanks Will , maybe you can figure out what i mean on my second post. two different set ups!

                                                                                 thanks again, Chef