Puppeteer

Author Topic: Slobbering=not enough temp or not enough load?  (Read 14867 times)

centralmainediesel

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: Slobbering=not enough temp or not enough load?
« Reply #15 on: February 18, 2009, 08:00:16 PM »
Just as an FYI.....I have not received any e-mails from anyone requesting information on our electric start models or otherwise. As many of you here on the Lister Forum know, I DO answer each and everyone of the e-mails, phone calls or letters we receive about any and all of our prodcuts. We are a small company dedicated to not only customer service, but back all of our products up with a warranty. The Lister-type engines we sell from Anand carry a full one year parts replacement warranty and I am usually quite liberal with that timeframe as well. Buy something from us, you get product backing and technical support. We don't know it all and we do pay close attention to what you folks have to say because this is where we have gathered much of our knowledge. Please send all your e-mail inquiries directly to me and I will make sure you get you answer. My address is philpepin@infionline.net  We do stock the 6/1, 12/1 and 24/2 electric start models. You cannot retrofit the starter kit on older models the way Anand has produced the kit (I take that back...many of you out there are extremely clever and most adaptive!!). I am just thinking of the "newbie" who wants to convert his current engine to electric start. The flywheel has a cogged adapter gear that is used to turn the flywheel when the electric start is activated. This cannot be used on current models as an "add on" feature (unlike something like our glow plug, which is easily added on). We are always here to help and just a phone call or e-mail away. Please direct all requests for information directly to me and I apologise, for whatever reason, we may have missed your e-mails....Thanks, Phil at Central Maine Diesel
« Last Edit: February 20, 2009, 08:31:29 PM by centralmainediesel »

piperpilot3tk

  • Full Member
  • ***
  • Posts: 195
    • View Profile
Re: Slobbering=not enough temp or not enough load?
« Reply #16 on: February 18, 2009, 10:44:03 PM »
Just sent Phil an email to the address he provided in the previous post, the last time I tried to contact him I was using his website and I did not email him directly. I am sure he will answer all of my questions. ;D

piperpilot3tk

  • Full Member
  • ***
  • Posts: 195
    • View Profile
Re: Slobbering=not enough temp or not enough load?
« Reply #17 on: February 19, 2009, 10:42:11 PM »
Got some info fron Phil at CMD today, he said he did not recommend retrofitting the elec start flywheels to an engine.  He also stated that they had some balancing problems on a few of the electric start models they imported from Anand.  He said all shipment of the electric start models will stop untill the problems are resolved.  Phil also spoke very highly of the Anand/Powerline engine's quality. He stated that in the past they have imported Metros, Field marshalls and two others that I cannot remember right now and all of them had serious quality issues. I am no expert on this and I have no hands on experiance with any make of listeroids, but from all the pictures, comments and videos I have seen, the Anands look to be the lesser of the evils. Any comment on the quality of the Anand/Powerline engines would be appreciated.  Thanks.
Mike