Puppeteer

Author Topic: bryce pump on petter pj1 will not prime  (Read 58 times)

rodc

  • Newbie
  • *
  • Posts: 3
    • View Profile
bryce pump on petter pj1 will not prime
« on: July 21, 2019, 12:32:41 PM »
hi
I have a fuel problem with which I am getting nowhere.
The original problem that the previous owner had was that the engine would start and then stop as if it had no fuel.
He unsuccessfully tinkered with the pump, so I decided to simply replace it for a fresh start and bought a replacement pump from stationaryengineparts.com.

The existing pump was a Bryce FA0AB080C0280 which was replaced by an FA0AB080C0770

Fitted the new pump, but the engine would not prime.
I bled the system as in the manual but the primer didn't really seem to be pushing fuel up the pipe although it was operating and I could see a change in fluid level at the top of the pump with the injector pipe disconnected but was expecting more of a burst rather than just a level change.
I took off the fuel pump housing cover plate to check the action of the tappet and primer and it seemed ok, although I'm new to these engines.

Regardless of how long I operate the primer no fuel comes out the pipe at the injector end.
Took the pipe off and blew it through with an airline.
Thought at first it was possibly drawing air in so spent an age sealing everything up around the fuel filter/pipes and bleed screws but to no avail.
I found yesterday afternoon that if I filled the tank so that the fuel level was above the injector, fuel simply flowed out of the pipe at the injector end in a continuous flow by gravity.

I don't think I did anything wrong when fitting the pump but I am stuck so there must be something

Any suggestions would be really appreciated.

thanks in advance

Rod

ajaffa1

  • Hero Member
  • *****
  • Posts: 1288
    • View Profile
Re: bryce pump on petter pj1 will not prime
« Reply #1 on: July 21, 2019, 02:22:19 PM »
Hi Rod, I am not familiar with your engine but my fist question is does your engine have a fuel lift pump and filter that send diesel to the fuel injection pump? My second question is does your injector pump have a small hole/inspection hole about one inch up from it`s base?

My first question relates to non delivery of fuel to the injector pump, this could be due to filter/fuel blockage or a damaged fuel lift pump. These lift pumps have a rubber diaphragm that does not last forever, they are generally driven by a short tappet rod off one of the cam lobes, these can also wear causing inadequate compression of the diaphragm. I have seen situations where too thick a gasket between the engine and fuel delivery pump is enough to stop them working.

My second question relates to whether or not the fuel injector pump is being driven up and down by the camshaft below, you should be able to see it`s action through the inspection hole, if it is not going up and down you have a problem with your cam or cam follower.

Please come back with what you find,

Bob

rodc

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: bryce pump on petter pj1 will not prime
« Reply #2 on: July 21, 2019, 06:17:50 PM »
hi
thanks for the response. The engine is the same as the PH1 as far as fuel is concerned.
I've attached a picture of the pump
It doesn't have a lift pump it is entirely gravity feed with the tank above the engine.
As part of my earlier struggle I replaced the fuel filter and all  the copper/fibre washers.
There is plenty of fuel getting as far as the injector pump which flows out of the bleed screw.

This afternoon I took off the pump case cover to expose the cam follower and primer.
I checked the primer and observed that it was pressing the cam follower up and down against the underside of the pump.
I then spun the engine and observed that the camshaft was causing the cam follower to also operate the pump.
So everything seems to be working apart from no pressure to the injector.
I'm starting to lean towards the very unlikely possibility of a faulty pump.

Rod

ajaffa1

  • Hero Member
  • *****
  • Posts: 1288
    • View Profile
Re: bryce pump on petter pj1 will not prime
« Reply #3 on: July 22, 2019, 12:03:51 AM »
Hi Rodc, If you have fuel to the injector pump, it`s been bled and the pump is being operated by the cam tappet and primer but it still pumps no fuel there are only two possibilities. The first is that you have a faulty pump the second is that the pump rack is too far to the left and is in the fully off position. Try disconnecting the linkage and manually push the rack all the way to the right, maximum fuel position. Now try your priming procedure and see if it pumps fuel.

I have read reports of new pumps not working because they have been in storage for a very long time. The diesel they were originally  tested with evaporates leaving a very nasty thick varnish that is a bugger to get rid of. Stripping a pump is not that difficult but does require absolute cleanliness. Do you know if this pump is brand new or is it a reconditioned unit. If it is reconditioned it may have been reassembled incorrectly.

Bob

38ac

  • Hero Member
  • *****
  • Posts: 1777
    • View Profile
Re: bryce pump on petter pj1 will not prime
« Reply #4 on: July 22, 2019, 12:37:59 AM »
That fuel will flow through the pump to the injector line by gravity means you most definitely have pump issues. The delivery valve in the pump should stop that ftom happening and the varnish that Bob mentioned could very well be the cause or it could be missing parts or assembeled wrong.
Collector and horder of about anything diesel

rodc

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: bryce pump on petter pj1 will not prime
« Reply #5 on: July 22, 2019, 10:18:45 AM »
many thanks both, it's really helpful to get your input.
The pump is a reconditioned one.
My original ignorance on these engines - although that's changing :-) - makes me reluctant to make judgements myself.
38ac's confirmation that the gravity flow is wrong is a great help.
Looking at the drawings I thought that should be so, but........

Having come down firmly on faulty pump, I sent a mail to the suppliers yesterday and hope to have an answer back today.
I think there must be a universal "Rods Box" for faulty stuff to go in that can be dipped into when I order things :-(

Many thanks again to you both, I'll report back once I hear from the suppliers

Rod

ajaffa1

  • Hero Member
  • *****
  • Posts: 1288
    • View Profile
Re: bryce pump on petter pj1 will not prime
« Reply #6 on: July 22, 2019, 12:52:20 PM »
Hi Rod, welcome to the diesel learning curve,enjoy it and let us know what you find out.

Bob

dieselspanner

  • Hero Member
  • *****
  • Posts: 591
    • View Profile
Re: bryce pump on petter pj1 will not prime
« Reply #7 on: July 22, 2019, 04:08:28 PM »
I had a Rajkot IP that I had to strip down and thoroughly clean out before it would run, it came with an injector that was nearly as bad.

Still there was zero corrosion.......

Cheers
Stef
Tighten 'til it strips, weld nut to chassis, peen stud, adjust with angle grinder.