Puppeteer

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Help I have a Lister

Pages: [1]
1
Engines / Re: SR2 bad vibrations
« on: September 01, 2018, 08:44:31 AM »
Thanks for your reply coopernook no itís still the same. I guess itís just a characteristic of the engine. Itís funny how some people approach me with compliments on how nice it sounds etc then going back to their smooth quiet modern engine brimming with the latest technology. Anyone want to make me an offer for this monster.

2
Engines / Re: SR2 bad vibrations
« on: August 11, 2018, 03:06:43 PM »
Thanks for your replies folks. Sorry for the delay in getting back. When I got the boat the engine was a poor starter and guffed like hell. I had the bores polished, new rings, a new valve, injectors checked, new crank shims and now it starts second turn, idles nicely  and is much cleaner. Iíll get a compression check and let you know. Cheers.

3
Engines / Re: SR2 bad vibrations
« on: August 06, 2018, 10:27:35 AM »
Thanks for your replies. The vibrations seem engine related as it is evident when revving in neutral. Engine mounts seem fine. Iíve looked at flexible mounts but it is a heavy engine and there is not much clearance to the mounting beams to fit anything substantial. If thereís nothing I can do with the engine then might just have to start saving up.

4
Engines / SR2 bad vibrations
« on: August 03, 2018, 08:26:05 AM »
My SR2 is solid mounted on a boat. It vibrates like hell is there anything that can be done.
Regards.

5
Engines / Re: SR2 issues
« on: December 07, 2014, 02:06:23 PM »
Ok thanks. I need a manual if you can help to see if it's anything I can do. Many thanks once again for your time.

6
Engines / Re: SR2 issues
« on: December 07, 2014, 10:52:00 AM »
Thanks for your reply.

The engine was submersed for up to 5 days. The smoke is blueish and consistent when the engine is warm. I have run it for about 10 hours like this.

Initially I had someone over who serviced the engine which included flushing and cleaning of fuel system and engine etc. with a new battery it turned over and eventually ran. I have noticed that the engine oil level seems to be lowering but there are no obvious leaks.

As I am unfamiliar with this engine I may have to call the service man back but before I spend any more money on it your comments are very much appreciated.

Regards.

7
Engines / SR2 issues
« on: December 06, 2014, 11:54:07 AM »
Hello out there. My first post. I have acquired a 30ft narrow boat with an SR2 with LH150 box. The boat sank and the engine was flooded. With some attention the engine was restarted. It takes a bit to get it started and once going It runs ok but chucks out a lot of smoke. Can anyone suggest what to do to improve the starting and emissions.

Pages: [1]